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SolidWorks 2011 includes many
enhancements and improvements, most
in direct response to customer requests.
This release focuses on the following
themes:

• Design faster and more efficiently

• Improved collaboration and
visualization

• Enhanced support for manufacturing

Top Enhancements

The top enhancements for SolidWorks 2011 provide improvements to existing products and

innovative new functionality. Throughout this guide, look for the symbol in these areas:

Fillets and Chamfers on page 23Assemblies

Weld Bead Display on page 165

Defeature for Assemblies on page 25

Alignment Options for Dimension Palette on page 43Drawings andDetailing

Auto Arrange Dimensions on page 49

Dual Unit Support on page 56

Weld Support in Drawings on page 169

Enterprise PDM Menus on page 65Enterprise PDM

DisplayManager on page 86Model Display

PhotoView 360 on page 90

Defeature for Parts on page 101Parts and Features

Sharing Equations Among Models on page 101

Suppression States of Features and Components on page
103



Surface Extrudes From a 2D or 3D Face on page 109

New 2D Simplification Study (Professional) on page 130Simulation

Weld Beads on page 164Weldments

Weld Bead Display on page 165

Fillets and Chamfers on page 166

For More Information

Use the following resources to learn about SolidWorks:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML • Help > What's New > PDF

• Help > What's New > HTML

In SolidWorks, click the symbol to display the section of this
manual that describes an enhancement. The symbol appears next

Interactive What's
New

to new menu items and the titles of new and changed
PropertyManagers.

To enable Interactive What's New, click Help > What's New >
Interactive.

What's New Examples are updated at every major release to provide
examples of how to use most top enhancements in the release.

To open What 's New Examples click Help >What's New >What's
New Examples.

What's New Examples

Contains complete coverage of our products, including details about
the user interface, samples, and examples.

Online Help

Provides information about late changes to our products.Release Notes
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This chapter includes the following topics:

• SolidWorks Search

• Save As and File Properties Buttons on Standard Toolbar

• PropertyManager Icons

• Error Reporting

New search modes have been added to SolidWorks Search. In addition to searching for
files and models, you can search SolidWorks Help, the Knowledge Base, or the community
forums.

On the Menu Bar, in the SolidWorks Search box , select the location to search and
type the text to search for.

See SolidWorks Help: Search.

The Standard toolbar now has two new buttons, Save As and File Properties . Use
Tools > Customize > Commands to add the buttons to a toolbar or the
CommandManager.

See SolidWorks Help: Customize Tool Buttons.

Icons for labels and buttons in PropertyManagers and dialog boxes are updated for greater
consistency with toolbar and FeatureManager design tree icons.



The SolidWorks Error Report dialog box now allows SolidWorks to gather more information
about why the software stopped responding.

The dialog box lets you do the following:

• Send a failure report to SolidWorks.

• Include a short description of your actions when the application stopped responding.

• Indicate whether this is a new problem or is similar to a previous problem. This
information helps SolidWorks Engineering identify stability trends.

• Preview the contents of the report to send to SolidWorks.

• View the SolidWorks data privacy policy. The reports are confidential, subject to this
policy.

To send reports to SolidWorks for every failure, select Enable performance feedback
in Tools > Options > General.
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This chapter includes the following topics:

• Application Programming Interface

• Pack and Go

• Documentation

Major enhancements are new interfaces, methods, properties, and delegates.

You can now:

• Display .NET controls in the SolidWorks user interface

• Access Pack and Go

• Get data objects containing curve, spline, and surface parameter properties

• Manage line styles in drawings

• Get the contents of folders in the FeatureManager design tree

• Create flyout groups in the CommandManager

• Convert draft quality drawing views to high quality

• Access a ray-trace rendering engine, such as PhotoView 360, and its options

• Determine whether the current sketch is a boundary box

• Get the direction of a bend line

• Get the boundary-box sketch display data of a flat-pattern drawing view

• Add and delete material from specific display states in the active configuration of a
model

• Add a standard SolidWorks or custom button to the Task Pane

• Get the name of the active PropertyManager page

• Get custom and stock render references for a model

• Get whether a command or PropertyManager page is active

• Add a line to a C# or VB.NET macro and to the SolidWorks journal file

• Send notification:

• Before a command or PropertyManager page executes or opens

• When a BOM or general table is inserted in an assembly, drawing, or part document

• After an entity is selected in a part, assembly, or drawing document

• Use Design Checker to:

• Build checks from existing SolidWorks documents, templates, and drawing standards

• Check against an existing file

• Get summary results and save its report in Microsoft Word format

Click Help > API Help > SolidWorks API Help > SolidWorks APIs > Release Notes.



New options on the Pack and Go dialog box let you save system-provided and custom
decals, appearances, and scenes associated with the model.

The options are:

• Include default decals, appearances and scenes

• Include custom decals, appearances and scenes

As an alternative to Pack and Go, go to Tools > Options > Document Properties
> Model Display and select Store Appearance, Decal and Scene data in model
file.

New Tutorials

SolidWorks 2011 includes the following tutorials: Assembly Visualization, Event-based
Motion Studies, Mouse Gestures, and SustainabilityXpress.

To access these tutorials:

1. Click Help > SolidWorks Tutorials.

2. Click one of the following:

• All SolidWorks Tutorials (Set 1)

• All SolidWorks Tutorials (Set 2)

3. Select a new tutorial from the list.

Toolbox Administration Overview

SolidWorks Help contains new Toolbox administration information.

See SolidWorks Help: Toolbox Administration Overview.
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This chapter includes the following topics:

• Defeature Tool

• Configuration Publisher

• 3D ContentCentral for Suppliers

Use the SolidWorks Defeature tool to remove details from a part or assembly and save
the results to a new file in which the details are replaced by dumb solids (that is, solids
without feature definition or history). You can then share the new file without revealing
all the design details of the model. For more information, see Defeature for Parts on
page 101.

Multiple Parent/Child Control

The Configuration Publisher offers more flexibility when defining data parents for controls.

You can define parents explicitly, and multiple parents are allowed. You no longer
automatically inherit grandparents (that is, the parents of controls which you have specified
as parents). See Parent/Child Relationships on page 37.

Model Tests

You can test the health of models before uploading them to 3D ContentCentral .

A sample of possible configurations is tested. Results are reported in a log file that lists
the configurations that were tested and whether they rebuilt successfully. See Model
Tests on page 37.

Supplier Services introduces new self-service publishing capabilities for industrial
component suppliers.

Part Numbers

Suppliers can use the Configuration Publisher to generate part numbers for a configurable
model, and users can search for models by part number on 3D ContentCentral. See Part
Numbers on page 36.



Model Health

Suppliers can test configurable models for Model Health in SolidWorks before uploading
them to 3D ContentCentral. See Model Tests on page 37.

Defeature Tool

Suppliers can enable the rules they have defined in SolidWorks to remove details from
configurable models prior to download. See Defeature for Parts on page 101.
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This chapter includes the following topics:

• Converting Files to SolidWorks 2011

• Installation Improvements

• SolidWorks Rx

Opening a SolidWorks document from an earlier release can take extra time. After you
open and save a file, subsequent opening time returns to normal.

You can use the SolidWorks Task Scheduler (SolidWorks Professional) to convert multiple
files from an earlier version to the SolidWorks 2011 format. Click Windows Start > All
Programs > SolidWorks 2011 > SolidWorks Tools > SolidWorks Task Scheduler.

In the Task Scheduler:

• Click Convert Files and specify the files or folders to convert.

• For files in a SolidWorks Workgroup PDM vault, use Convert Workgroup PDM Files.

For files in a SolidWorks Enterprise PDM vault, use the utility provided with Enterprise
PDM.

After you convert files to SolidWorks 2011, you cannot open them in older versions
of SolidWorks.

SolidWorks Installation Manager and the installation process have significant
improvements.

License Activation

SolidWorks License Activation is enhanced.

• You can activate and transfer licenses for multiple serial numbers in a single step.

• You can transfer a license from a computer even if SolidWorks is no longer installed
on that computer. You can download and run SolidWorks Activation Wizard from the
SolidWorks customer portal to transfer the license.

SolidNetWork License Manager

SolidNetWork License Manager is enhanced.

• The display of borrowed licenses is improved.



• The list of product licenses available to borrow now shows only what has been purchased
and is available on the SolidNetWork License Manager.

• Borrowing a SolidWorks package license now automatically borrows the pre-requisite
SolidWorks Standard license.

• You can update SolidNetWork License Manager to a new version using SolidWorks
Installation Manager, rather than removing the previous version and then installing
the new one.

Installation Manager

SolidWorks Installation Manager is enhanced.

• You can specify which languages to include in the SolidWorks product installation,
rather than installing all languages. English is always installed, even if you do not
specify it during installation.

The Languages specification in the Product Summary applies only to the
SolidWorks product installation. It does not apply to other product installations
such as SolidWorks eDrawings , SolidWorks Workgroup PDM, and SolidWorks
Explorer, which install all languages.

• The Workgroup PDM and SolidNetWork License Manager installations are more integrated
into the SolidWorks Installation Manager workflow.

• You can create 32-bit and 64-bit administrative images on both 32-bit and 64-bit
operating systems. For example, you can:

• Create a 32-bit image on a 64-bit operating system

• Create a 64-bit image on a 32-bit operating system

• Create 32-bit and 64-bit images on the same operating system

Administrative Image Option Editor

The interface and workflow for SolidWorks Administrative Image Option Editor are
enhanced.

• The Option Editor opens automatically after SolidWorks Installation Manager creates
the administrative image.

• You can manage both 32-bit and 64-bit administrative images using the same Option
Editor on either a 32-bit or a 64-bit operating system.

• You can perform all administrative image configuration steps using SolidWorks
Administrative Image Option Editor (some of which were handled previously in
SolidWorks Installation Manager).

• In SolidWorks Administrative Image Option Editor, you can specify whether automatic
updating is enabled for one or more machines or groups. You also can specify when
the update occurs for specific machines or group of machines. This allows you to manage
automatic updates (for example, avoiding the overload of a particular server because
all the updates take place simultaneously).

Background Downloader

You can use SolidWorks Background Downloader to download installation files in the
background. You are notified when downloading is complete and the files are ready for
installation. You can choose to install now, delay the installation, or delete the download.



Diagnostics

The improved page design and content on the Diagnostics tab helps you locate and
download the correct graphics driver at
http://www.solidworks.com/sw/support/videocardtesting.html.

Status shown in the Diagnostics tab for different system and graphics card combinations
on your machine:

All system and graphics card related
fieldsCertifiedSystem

Certified only for
previous version
of SolidWorks

Graphics
Card

Graphics card related information
Not certifiedSystem

Certified only for
previous version
of SolidWorks

Graphics
Card

All system and graphics card related
fieldsCertifiedSystem

Out-of-dateGraphics
Card

All system and graphics card related
fieldsCertifiedSystem

CurrentGraphics
Card

If you have no internet connection, the status shows the error icon .

Usability and Workflow Improvements

The Problem Capture tab helps you describe the problem, record the video, and package
the SolidWorks files.

1. On the Problem Capture tab, click Describe Problem.

2. In the Problem Capture Details dialog box, describe the problem and click OK

This dialog box has been shortened to improve usability.

3. Click Record Video.
A new SolidWorks session starts. This button replaces the Re-create the problem
dialog box.

4. In the Capturing Problem dialog box, click Start Recording.



The floating dialog box stays on top of your SolidWorks session.

5. Record the problem and click Finish Recording.

6. When prompted to shut down the SolidWorks session, click OK.

7. Click Add Files to add parts, drawings, or assembly files, then click Package files
Now.
A zipped folder is created. You can rename the folder, save it on your hard disk, and
send it to the Technical Support team.

Hardware Benchmarks

The Addins tab now has a link to www.solidworks.com/benchmarks for you to find details
about running SolidWorks and computer-related benchmarks. You can determine whether
your system is qualified to run SolidWorks effectively.

To run the SolidWorks performance benchmark, on the Addins tab, click Start the
SolidWorks Performance Benchmark.

Graphics Card Health Checker

Enhancements to the Graphics Card Drivers page help you identify the correct graphics
driver. See http://www.solidworks.com/sw/support/videocardtesting.html .

Improvements:

• A one-click application that profiles your system and graphics card, and populates the
information on the web page for you to identify the correct graphics card.

You need .NET 2.0 or later installed on your machine to view this button on the
web page.

• An updated results chart with color-coded keys that improves readability.
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This chapter includes the following topics:

• Assembly Features

• Assembly Visualization

• Defeature for Assemblies

• Equations

• Interference Detection

• Mates

• Rebuild Report

• SpeedPak

Enhancements include the ability to add fillets, chamfers, and weld beads to assemblies.

Fillets and Chamfers

In assemblies, you can create fillets and chamfers, which are useful for weld preparation.
As with other assembly features, you can propagate these features to the parts they
affect.

For a step-by-step example of adding chamfers in an assembly, see Fillets and Chamfers
on page 166.

Weld Beads

You can add simplified weld beads to assemblies. Simplified weld beads provide a
lightweight, simple representation of weld beads.



In previous versions of SolidWorks , you added weld beads as components of the
assembly. This method is no longer supported. However, you can still edit existing
weld bead components.

For more information about simplified weld beads, see Weld Beads on page 164.

For a step-by-step example of adding a weld bead to an assembly, see Weld Beads on
page 165.

Enhancements support complex sorting scenarios and provide additional display and save
options.

Sorting and Column Options

You can build more complex sorting scenarios by doing the following:

• Adding multiple columns

• Adding multiple parameters to the sorting hierarchy

• Rearranging column position to change the order in which the parameters are sorted

Right-click a column header and select the following:

• Add Column. Adds a column to the Assembly Visualization list. You can then change
which property is listed in the new column.

• Delete Current. Deletes the column you right-clicked. The minimum number of columns
is three. The File Name and Quantity columns cannot be deleted.

• Add to Sort Hierarchy. Enables you to sort by the values in that column. A sorting
widget appears under the column title. To remove a column from the sort hierarchy,
right-click it and click Remove from Sort Hierarchy. When multiple columns have
sorting widgets, the hierarchy of the sort is from left to right. Drag a column header
to move a column left or right to move it up or down in the sorting hierarchy.

You can adjust the width of a column to fit the column contents by double-clicking
the column separator.

Save and Display Options

With enhanced save and display capabilities, you can:

• Export the Assembly Visualization list in top-level only, parts only, or indented format
when saving the list to a separate file. Right-click any column header and click Save
as. Then in the Save As dialog box, select Top-level only, Parts only, or Indented.

• Save the Assembly Visualization view as a display state. Click the arrow to the right
of the column headers and click Add Display State.



• Apply the same color to components that have identical values (for example, when
components are sorted by a discrete property such as Vendor or Status). Right-click
a color slider and click Group Identical. The software adds sliders as needed to apply
a distinct color for each discrete value.

• Set the length of the value bars to be calculated as a percentage of the value for the
highest-value component or as a percentage of the value for the entire assembly. Click
the arrow to the right of the column headers, click Value Bars, and then click
Component Driven or Assembly Driven.

With the Defeature tool, you can remove details from a part or assembly and save the
results to a new file in which the details are replaced by dumb solids (that is, solids without
feature definition or history). You can then share the new file without revealing all the
design details of the model.

AfterBefore

Click Defeature (Tools toolbar) or Tools > Defeature to access the Defeature
PropertyManager, which provides tools for manual and automatic selection of details to
keep and remove.

The PropertyManager has multiple pages.

Defeature - Step 1: Components

You can specify components to remove from the model.

In this example, you use the Defeature tool to remove all internal components and
features, and some external features, from an oil pump assembly. You retain the mounting
holes.

1. Open install_dir\samples\whatsnew\assemblies\oil_pump.sldasm.

2. Click Tools > Defeature.



The Defeature PropertyManager opens to Step1: Components.

First, examine a section view of the assembly.

3. In the PropertyManager, under Section View, click Plane1 .
You can see internal details and components.

Change Offset Distance to view different sections of the assembly.

4. Click Plane1 to clear the section view.

5. Under Remove, select Internal components.

6. Click Next .

Defeature - Step 2: Motion

If you want to allow motion in an assembly, you can remove details from groups of
components and allow motion between the groups.

For this example, skip this step.

Click Next .

Defeature - Step 3: To Keep

You can specify features that you want to retain, such as mounting holes, that might
otherwise be removed by the Defeature tool.

1. For Features to Keep :

a) In the graphics area, select the three mounting holes on the cover.

b) Rotate the assembly and select the three mounting holes on the housing.



2. Click Next .
The screen splits and a preview of the model appears. Features on the housing are
removed to close up the assembly. The mounting holes you selected are retained.

When you rotate the assembly, the preview also rotates.

PreviewAssembly

Defeature - Step 4: To Remove

You can specify to remove features that were not automatically removed.

1. In the flyout FeatureManager design tree, expand Cover and select Rib Cut.
In the PropertyManager, Rib Cut and its dependent features appear in Items to

Remove . In the graphics area, the cut feature is highlighted.

2. Click Next .
The preview shows that the cut feature is removed.



Defeature - Feature Removal Complete

You can save the less-detailed model in a separate part file or publish it to 3D
ContentCentral. The settings you select in the PropertyManager are saved in the original
model.

1. Under Results, select Save the model as a separate file.

2. Click .

3. In the Save As dialog box:

a) For File name, type oil pump - details removed.

b) For Save as type, select Part(*.sldprt).

c) Click Save.

The assembly is saved as a part. The part has only one feature, Imported1 , and
has no references to the original assembly.

In the assembly, Defeature appears near the top of the FeatureManager design
tree.

You can right-click Defeature , click Edit Feature , change the settings, and
save another version of the assembly, with different details removed.

4. In the part window, click Section View (Heads-Up toolbar) or View > Display
> Section View.
The part has no internal details.



Equation functionality is enhanced.

• You can use equations to control the suppression state of assembly components.

• You can share equations and global variables among models.

• You can configure global variables.

See Equations on page 101.

Interference Detection has been enhanced.

Ignore Hidden Bodies

You can ignore interferences with hidden bodies.

For example, suppose that in a multibody part, you create a body for construction purposes
and then hide it. In an assembly, you can choose to not show interferences between the
hidden body and other components.

Click Interference Detection (Assembly toolbar) or Tools > Interference
Detection. In the PropertyManager, under Options, select Ignore hidden bodies.

Quality and Performance

The quality and performance of Interference Detection have been improved. Because
of the changes, the software might find interferences that were previously missed, resulting
in changes in the number of interferences reported.

Replace Mate Entities

Replace Mate Entities is enhanced.

• The Missing Entities popup toolbar is now available while you replace any mate entities,
not just while you replace a component that includes mate entities.



• While replacing multiple mate entities, you can postpone the solving of the mates.
Select Defer update so that all mates are solved together when you exit the
PropertyManager, instead of solving individually each time you select a replacement
entity.

Select a mate, a component, or a Mates folder and click Replace Mate Entities
(Assembly toolbar).

Mates in Motion

To support more accurate motion simulations, certain mates are now solved relative to
other components rather than relative to the assembly origin.

The reference components for gear mates, rack and pinion mates, and screw mates are
detected automatically. For linear/linear coupler mates, you specify the appropriate
reference components in the Mate PropertyManager.

The reference component information is used in SolidWorks Motion simulations.

AssemblyXpert now provides a report of the rebuild time for the total assembly.

You must rebuild the assembly during the current session of SolidWorks before
generating the report.

1. Click AssemblyXpert (Assembly toolbar) or Tools > AssemblyXpert.

2. In the AssemblyXpert dialog box, in the information-only row about the rebuild report,

click Show these Parts .

New commands make it easier to switch between SpeedPak and parent configurations of
subassemblies. Also, sketches now appear in SpeedPak configurations.

Switching All Subassemblies to SpeedPak

Do one of the following:

• When opening an assembly, click Open (Standard toolbar) or File > Open. In the
Open dialog box, select Use SpeedPak.

• In an assembly that is already open, in the FeatureManager design tree, right-click the
top-level assembly and click Use SpeedPak.

If a subassembly's active configuration has a SpeedPak configuration, then the SpeedPak
configuration is used.

Switching Selected Subassemblies to SpeedPak

In the FeatureManager design tree, right-click one or more subassemblies and click Use
SpeedPak.

If the selected subassembly's active configuration has a SpeedPak configuration, then
the SpeedPak configuration is used.



Switching from SpeedPak to Parent Configurations

In the FeatureManager design tree, right-click the top-level assembly or one or more
selected subassemblies and click Set SpeedPak to Parent.

The subassemblies switch from the SpeedPak configuration to the SpeedPak's parent
configuration.

Sketches in SpeedPak Configurations

Unabsorbed sketches are included in SpeedPak configurations. You can suppress unneeded
sketches to avoid having them affect performance of the SpeedPak configuration. As in
any assembly, you suppress and unsuppress sketches by right-clicking them in the

FeatureManager design tree and selecting Suppress or Unsuppress .
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This chapter includes the following topics:

• Configuration Publisher

• Modify Configurations

• Parameters

• SpeedPak

3D ContentCentral

The Configuration Publisher has new capabilities for 3D ContentCentral suppliers.

Part Numbers
A part number can be displayed with your model on 3D ContentCentral. Your customers
can search for the model by part number.

To include a part number with the model:

1. In the design table of the model, create a column with the header $PARTNUMBER.

2. Under $PARTNUMBER:

• For single-row design tables, use Microsoft Excel functions such as CONCATENATE
to make the value of the cell reflect the model's part number based on values in
other columns.

• For multiple-row design tables, enter a part number for each configuration by
typing or using Microsoft Excel functions.

3. In the Configuration Publisher, add controls, rules, and values.
On the 3DCC Preview tab, Supplier part number displays the part number of the
selected configuration. As you change selections, the part number updates to reflect
the current selections.

4. Click Upload to 3D ContentCentral and click Yes to save the model.
The software generates a list of part numbers and stores it within the model in a
format that is accessible to the 3D ContentCentral software.

• For single-configuration models, a part number is generated for each possible
configuration, based on the rules and values you defined in the Configuration
Publisher.

• For multiple-configuration models, the list contains the part numbers you entered
for each configuration in the design table.

On 3D ContentCentral:



• On the Configure & Download page, the part number appears at the bottom of the
Configure area and updates as you change selections.

• You can search for the model by part number or partial part number.

Model Tests
You can test the health of models before uploading them to 3D ContentCentral.

A sample of possible configurations is tested. Results are reported in a log file that lists
the configurations that were tested and whether they rebuilt successfully.

To test a model before uploading it:

1. In the Configuration Publisher, on the 3DCC Preview tab, click Test.

2. In the Configuration Tester dialog box, specify the sample size and where to store the
log file, and click Begin Test.

The dialog box reports the percentage of the samples that succeeded. You can view the
log file for more details.

Parent/Child Relationships

The Configuration Publisher offers more flexibility when defining data parents for controls.

You can define parents explicitly, and multiple parents are allowed. You no longer
automatically inherit grandparents (that is, the parents of controls which you have specified
as parents).

You must have at least two controls already defined. Then you can add multiple data
parents to the third or later controls.

In the Configuration Publisher, under Data, one Parent field is initially visible. To add

others, click Add Parent .

The Modify Configurations dialog box has been enhanced.

• The All Parameters option has been moved from the table view drop-down list to a

separate button .

• Linked dimensions are grouped in a column labeled Linked Dimension instead of
appearing in columns for individual features. Each linked dimension appears in the list
only once, even if it is used in several features.

Right-click an item and select Configure dimension, Configure feature, Configure
component, or Configure Material.

You can configure parameters in the following areas.

• Scale features (See Scale on page 109.)

• Global variables (See Global Variables on page 106.)

• Cosmetic threads (See Cosmetic Threads on page 53.)



New commands make it easier to switch between SpeedPak and parent configurations of
subassemblies. Also, sketches now appear in SpeedPak configurations.

For more information, see SpeedPak on page 30.



You can use the new Design Checker task inside the Administration Tool of Enterprise
PDM to validate selected SolidWorks documents in the vault using standards files (.swstd)
created in Design Checker.

See Design Checker Validation on page 71.



9

This chapter includes the following topics:

• Injection Molding

• Running an Injection Molding Check

DFMXpress supports injection molded parts. You set the Minimum wall thickness and
Maximumwall thickness parameters that DFMXpress uses to validate manufacturability.

1. With a part open, click Tools > DFMXpress.

2. Click Settings.

3. Under Manufacturing Process, select Injection Molding.

4. Under Rule Parameters, set Minimum wall thickness and Maximum wall
thickness.

5. Click Run.
The Manufacturing Process: Injection Molding report displays a list of rules
passed and rules failed.
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This chapter includes the following topics:

• Alignment Options for Dimension Palette

• Auto Arrange Dimensions

• Bounding Box for Sheet Metal

• Cut List Properties in Drawings

• Center Marks in Assembly Drawings

• Cosmetic Threads

• Display Scale in Orthogonal Views

• Drawing Sheet Format

• Dual Dimensions for Chamfers

• Hide Bodies in Drawing View

• Hole Tables

• Merge and Unmerge Cells in Tables

• Notes

• Show Dimension Units

• Show Model Colors in Drawings

• GB Drafting Standard

• ANSI Drafting Standard

• 3D Drawing Views

Alignment tools are available on the dimension palette when you select more than one
dimension.

To display the dimension palette, select dimensions and move the pointer over the

Dimension Palette rollover button .



The following alignment tools are on the dimension palette.

These tools are also available on the Align toolbar.

Auto Arrange Dimensions

Automatically arranges selected dimensions. See Auto Arrange Dimensions on page
49.



Space Evenly Linear/Radial

Equally spaces all dimensions, linearly or radially, between the closest and furthest
selected dimensions from the part.

Linear

AfterBefore

Radial

AfterBefore



Align Collinear

Aligns dimensions horizontally, vertically, or radially.

AfterBefore

Align Stagger

Staggers linear dimensions.

AfterBefore



Top Justify Dimension Text

Top justifies linear dimension text.

AfterBefore

Bottom Justify Dimension Text

Bottom justifies linear dimension text.

AfterBefore



Left Justify Dimension Text

Left justifies linear dimension text.

AfterBefore

Right Justify Dimension Text

Right justifies linear dimension text.

AfterBefore

You can adjust the spacing between dimensions using the thumbwheel in the dimension
palette or by manually dragging the dimensions.



• The thumbwheel appears in the dimension palette only when spacing options are
available.

• The Dimension Spacing Value is the scaling factor for the spacing. For example,
2 increases the spacing by a factor of 2, or doubles it.

The Auto Arrange Dimensions tool positions dimensions quickly and easily.

When you use Auto Arrange Dimensions , the selected dimensions are placed as
follows:

• Spaced from smallest to largest

• Aligned and centered, if possible

• Spaced with the offset distances defined in Document Properties - Dimensions

• Adjusted to avoid overlapping

• Staggered, if necessary

Using Auto Arrange Dimensions

To use Auto Arrange Dimensions:

1. Open install_dir\samples\whatsnew\drawings\Auto_arrange.SLDDRW.

2. Box select all of the dimensions.

3. Move the pointer over the Dimension Palette rollover button to display the
dimension palette.

4. Click Auto Arrange Dimensions .

5. Click in the graphics area off of the dimension palette.
The dimensions are automatically arranged.



Adjusting Spacing

To adjust the horizontal spacing in the dimensions at the top of the drawing:

1. Select the horizontal dimensions at the top of the drawing and display the dimension
palette.

2. Move the thumbwheel to the right and left to adjust the Dimension Spacing Value.

You can display a bounding box that fits a flat pattern for sheet metal parts and bodies,
with or without grain direction.



Bounding BoxNo Bounding Box

To display the bounding box:

1. Right-click a drawing view and click Properties.

2. In the Drawing View Properties dialog box, select Display bounding box.

To set grain direction:

1. In the part, edit the Flat Pattern feature.

2. Click in Grain Direction.

3. Select an edge or sketch line to define the grain direction.

4. Click .



You can insert the cut list properties as an annotation when you insert a flat pattern view
of a sheet metal part in a drawing.

To insert the cut list properties:

1. In the graphics area, right-click the flat pattern view and click Annotations > Cut
List Properties.

2. Click to place the list in the graphics area.

You can insert center marks automatically in assembly drawings.

To insert center marks on holes, fillets, or slots automatically in assembly drawing views:

1. In an assembly drawing document, click Options (Standard toolbar) or Tools >
Options.

2. On the Document Properties tab, click Detailing.

3. Under Auto insert on view creation, select from:

• Center marks - holes - assembly

• Center marks - fillets - assembly

• Center marks - slots - assembly



You can configure callouts for cosmetic threads.

Cosmetic thread callouts are editable, and therefore configurable, only when Standard
is set to None in the Cosmetic Thread PropertyManager.

Use one of the following methods:

Under Thread Callout, click Configurations and specify the
configurations to which the callout applies.

PropertyManager

The column header for controlling the callout of a cosmetic thread
uses this syntax:

$THREAD_CALLOUT@cosmetic_thread_feature_name

Design Table

Example:



You can display the scale of an orthogonal view if the scale is different than the default
drawing scale. Previously, you could only display the scale of a detail, section, or auxiliary
view in a drawing.

To display the scale of an orthogonal view:

1. In a drawing, click Options (Standard toolbar) or Tools > Options.

2. On the Document Properties tab, expand View Labels and click Orthographic.

3. Select Show label if view scale differs from sheet scale.

4. Click OK.

Scale Not DisplayedScale Displayed

The default location for storing drawing sheet formats is now at:

C:Documents and Settings\All Users\Application

Data\SolidWorks\version\lang\language\sheetformat

Windows XP

C:ProgramData\SolidWorks\version\lang\language\sheetformatWindows 7

C:ProgramData\SolidWorks\version\lang\language\sheetformatWindows Vista

To change the default location, click Tools > Options > System Options > File
Locations. In Show folder for, select Sheet Formats.

You can display dual units in chamfer dimensions. For example, you can display the
chamfer dimensions in inches and centimeters.

To display dual dimensions for all chamfers in a drawing, click Tools > Options >
Document Properties > Dimensions > Chamfer. Under Dual dimensions, select
Dual dimensions display. To display units, select Show units for dual display.



To display dual dimensions for a particular chamfer, select the chamfer dimension and
then in the Dimension PropertyManager, select Dual Dimension.

In addition to hiding components in a drawing view, you can now hide a body in a drawing
view.

Hiding a Body

To hide a body:

In the drawing view, right-click the body and click Show/Hide, then Hide Body.

Showing a Body

To show a body:

1. In the FeatureManager design tree or graphics area, right-click the drawing view and
click Properties.

2. In the Drawing View Properties dialog box on the Hide/Show Bodies tab, select the
body to view and press Delete.

3. Click OK.

Tags

You can renumber the tags when you add or delete holes from a hole table.

Renumbering All Tags

To renumber all tags:

Right-click the hole table in the graphics area or in the FeatureManager design tree
and select Renumber All Tags.

Renumbering a Series

To renumber a series:

Right-click any row in the series and select Renumber Series.
In this example, hole A3 is removed and the corresponding A series is renumbered.



After renumbering seriesBefore renumbering series

Dual Unit Support

You can display dual units in hole tables. For example, you can display the size of a hole
in millimeters and inches.

To display dual dimensions in hole tables, click Tools > Options > Document Properties
> Tables > Hole. Under Dual dimensions, select Dual dimensions display. To display
units, select Show units for dual display.

You can also right-click a hole table and click Show dual dimensions. When dual
dimensions are displayed, you can right-click the hole table and click Show units for
dual dimensions.

You can merge and unmerge cells in a table using tools from the Table pop-up toolbar.

To merge cells:

1. Select the cells.

2. Click Merge Cells (Table pop-up toolbar).

To unmerge cells:

1. Select the cell.

2. Click Unmerge a Cell (Table pop-up toolbar).



Fit Text in Notes

The Fit Text tool is available in the PropertyManager and pop-up toolbar when you
create notes. Previously, it was available only when you edited notes.

Pattern Notes

You can display notes in linear or circular patterns in drawings.

First create a note, then create the linear or circular pattern of the note.

1. In a drawing, click Note (Annotation toolbar) or Insert > Annotations > Note.

2. In the PropertyManager, set the options for the note and place it in the drawing.

3. To create a circular note pattern, click Circular Note Pattern (Annotations toolbar),
or click Insert > Annotations > Circular Note Pattern.

4. In the PropertyManager, set the options.

5. To edit the notes, double-click each note and enter the text.



You can show dimension units in drawings.

1. In a drawing, click Options (Standard toolbar) or Tools > Options.

2. On the Document Properties tab, click Dimensions and select Show units of
dimensions.

3. Click OK.

You can view the model colors of a part or assembly in a drawing in HLR/HLV. Any assigned
layer overrides this setting.

To show model colors, click Tools > Options > Document Properties > Detailing.
Select Use model color for HLR/HLV in drawings.

Drawing with colorsAssembly with colors



Additional requirements of the GB drafting standard are supported.

In Tools > Options > Document Properties > Dimensions:

• Arrow length increased from 3.3mm to 4.08mm.

• Arrows changed from hollow to solid.

• Extension line:

• Gap changed from 1mm to 0mm.

• Beyond dimension line changed from 1mm to 2mm.

In Tools > Options > Document Properties > Dimensions > Chamfer, a new Text

position option, Horizontal Text, along the model line extension, puts the
chamfer dimension in line with the model edge.

The SolidWorks software supports some of the requirements of ASME Y14.5-2009.

Datum Feature Symbols

Leaders
You can use leaders for datum feature symbols that you apply to planar surfaces.

Click Datum Feature (Annotation toolbar) or Insert > Annotations > Datum

Feature Symbol. In the PropertyManager, under Leader, click Leader or No Leader

.

Attachment to Linear Dimensions
You can attach datum feature symbols to linear dimensions.

Click Datum Feature (Annotation toolbar) or Insert > Annotations > Datum
Feature Symbol. In the PropertyManager, set the options, then select a linear dimension
to which you want to attach the symbol. The datum is placed in the center of the
dimension.



If you attach the symbol to a dimension that is centered between its extension lines,
the symbol is placed as shown.

Geometric Tolerance Symbols

Leaders
All Over Leader is available as a new leader type.

Click Geometric Tolerance (Annotation toolbar) or Insert > Annotations >
Geometric Tolerance. In the PropertyManager, under Leader, click All Over Leader

.
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Available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

• Display Enhancements

• File Synchronization

• Triad Manipulation

• Filtering by Component Name

• Native 64-Bit Support

The performance of display and printing in SolidWorks eDrawings is significantly
improved for some documents.

eDrawings now displays DWG files more accurately. Gradient hatches are supported, and
the handling of overlapping entities more closely matches the display order used in
AutoCAD.

eDrawings can now detect when the graphics data for a component may not be in sync
with a later version modified and saved within a SolidWorks assembly.

When you open a potentially outdated component, a watermark displays a warning and
suggests that you rebuild the part in SolidWorks.

To control the display of the watermark during the session, click View > ShowWarning
Watermark.

You can manipulate components of an assembly with greater control and precision.

You can use the triad tool to constrain component movement to a coordinate axis or plane
and to rotate components about a coordinate axis. You can also enter values to specify
position, translation, or rotation.

Click Tools > Move Component and select Use triad or enter values.

You can filter the assembly tree to show component names that contain text you specify.
This feature was previously available only in eDrawings for Mac .



In the Component tree , type your search text in Enter text to filter list .

SolidWorks eDrawings software can now run as a native 64-bit application on a 64-bit
Microsoft Windows operating system, which permits larger documents to be opened.
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This chapter includes the following topics:

• Exporting .IFC Files

• DXF DWG Import Wizard

• Exporting Sheet Metal Parts to DXF or DWG Files

You can export SolidWorks models to the Industry Foundation Classes .ifc files format.

To export SolidWorks models as .ifc files:

1. Click File > Save As.

2. For Save as type, select IFC 2x3.

3. Navigate to the correct folder and enter a file name.

4. Click Options, select the OmniClass and units, and click OK.

5. Click Save.

For more information, see SolidWorks Help: .IFC Files.

Importing Layers from .DWG or .DXF Files

When importing a .dwg or .dxf file as a 2D sketch for a part, you can create a new sketch
for each layer in the file.

1. Open a .dwg file with layers.

2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.

3. Click Next.

4. Select Import each layer to a new sketch.

5. Select other options and click Next or Finish.

Defining the Sketch Origin and Orientation on .DWG or .DXF Import

When importing a .dwg or .dxf file as a 2D sketch for a part, you can define the model
origin and orientation.

1. Open a .dwg file.

2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.

3. Click Next.

4. Select part document options and click Next.



5. Click Define Sketch Origin and click a point in the sketch preview to define the
origin.

6. Adjust the origin values and click Apply.

7. To change the model orientation about the origin, select Rotate about the origin
and enter the angle of rotation.

8. Select other options and click Finish.

Filtering Sketch Entities on .DWG or .DXF Import

When importing a .dwg or .dxf file as a 2D sketch for a part, you can filter out unnecessary
entities.

1. Open a .dwg file.

2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.

3. Click Next.

4. Select part document options and click Next.

5. In the preview, select entities to remove and click Remove Entities.

To undo this action, click Undo Remove Entities .

6. Select other options and click Finish.

Repairing Sketches After .DWG or .DXF Import

When importing a .dwg or .dxf file as a 2D sketch for a part, you can launch the
SolidWorks Repair Sketch tool from the DXF/DWG Import Wizard to fix gap or overlap
errors after import.

1. Open a .dwg file.

2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.

3. Click Next.

4. Select part document options and click Next.

5. Select Run Repair Sketch.

6. Select other options and click Finish.

Exporting a Bounding Box

When exporting a sheet metal part as a .dxf or .dwg file, you can export the bounding
box and assign the bounding box to a specific layer.

To assign the bounding box sketch to a layer:

1. Click File > Save As.

2. For file type, select .dxf or .dwg.

3. Click Options.

4. In the DXF/ DWG Output PropertyManager, under Entities to Export, select Bounding
box.

5. Select other options and click .

6. In the SolidWorks to DXF/DWG Mapping dialog box:



Assign layers to entities.•

• Map other properties.

• Click OK.

Exporting Bend Line Directions

You can map bend line directions to specific layers when you export sheet metal models
as .dxf or .dwg files. For example, in sheet metal parts with up and down bend directions,
you can map the different bend line directions to separate layers when you export the
part.

To export and map bend line directions for a sheet metal part:

1. Click File > Save As.

2. For file type, select .dxf or .dwg.

3. Click Options.

4. Under Custom Map SolidWorks to DXF/DWG, select Enable.

5. Set other export options and click OK.

6. In the DXF/ DWG Output PropertyManager, under Entities to Export, select Bend
lines.

7. Select other options and click .

8. In the SolidWorks to DXF/DWG Mapping dialog box:

• Assign layers to entities.

• Map other properties.

• Click OK.
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Large Scale Design helps you use the tools that the SolidWorks software offers for creating
equipment, facilities, and plants.

This chapter includes the following topics:

• Walk-through

• Exporting .IFC Files

• Grid System

You can use theWalk-through function to explore or create a video of the 3D geometry
of plants or other systems. You “see” the geometry of the system as you maneuver
through it. You can save what you see and play it back for further study.

To activate the function, click View > Lights and Cameras > Add Walk Through.

Define motion constraints and other parameters, such as the camera height, in the
PropertyManager, and click Capture Motion to open the control panel. Define your

starting point, click Record , and use the controls to maneuver through the system.

You can also use the arrow keys and the mouse to maneuver through the system. You
may eventually find that a combination of mouse and keyboard controls allows you to
maneuver through the system most efficiently.

To use the mouse, left-click to manipulate the view.

The keyboard controls are:



Move forward or back, turn left or right.Arrows

Move up, down, left, or right.Shift + arrows

Turn up or down.Control + arrows

Look up, down, left, or right. Press the Alt
and arrow keys simultaneously.

Alt + arrows

Reset “view” direction.Home

Zoom out or in.Z, Shift + Z

Increase or decrease speed.+, -

Set speed.1 - 9

Lock to constraint.Scroll Lock

Next constraint.Page Up

Previous constraint.Page Down

Record.R

Pause.Space

Cancel.Esc

Toggle map view.M

You can export SolidWorks models to the Industry Foundation Classes .ifc files format.

To export SolidWorks models as .ifc files:

1. Click File > Save As.

2. For Save as type, select IFC 2x3.

3. Navigate to the correct folder and enter a file name.



4. Click Options, select the OmniClass and units, and click OK.

5. Click Save.

For more information, see SolidWorks Help: .IFC Files.

You can use the Grid System tool to lay out a grid system for large structures. The grid
system is useful when creating welded structures. The grid system is also helpful when
you work with multiple users who use different third-party applications to make grids.
Multiple users can use the grid system and work from the same baseline.

You can create a grid to help specify the location of key elements in structures. When
you use the Grid System tool, you create a sketch to represent the grid. You can then
specify the number of floors for the structure and the distance between each floor. The
sketch is replicated for every floor in the structure. Balloons are attached to the grid items
to help with orientation.

Grid system with weldments appliedGrid system sketch

Click Grid System (Features toolbar) or Insert > Reference Geometry > Grid
System.

See SolidWorks Help: Creating a Grid System.

The graphics area can appear cluttered when the grid system creates a lot of geometry
or if you create multiple grid systems. To reduce clutter, you can hide the geometry.
Display options are available to help you visualize the grid structure and to ensure correct
grid inferencing.



To access the display options, in the FeatureManager design tree, right-click Grid System

and click View Grid Components. In the View Grid Components dialog box, select

an item and click a display option, such as Normal To .
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This chapter includes the following topics:

• DisplayManager

• Appearances

• Lights

• Scenes

• Decals

• PhotoView 360

• Working with Appearances and Rendering a Model

The SolidWorks DisplayManager is the central location for managing appearances, decals,
scenes, cameras, lights, and Walk Through. Use the DisplayManager to view, edit, and
delete display items applied to the current model.

On the Manager Pane, click the DisplayManager tab .

See SolidWorks Help: DisplayManager.

All appearance functionality, including controls previously available only in PhotoView or
PhotoWorks , is now available in SolidWorks Standard. The DisplayManager lists the
appearances applied to the currently active model. You can also save custom appearances
in SolidWorks Standard.

On the DisplayManager tab, click View Appearances .



See SolidWorks Help: Appearances.

The DisplayManager is the central location for managing all aspects of lighting, including
lighting controls that are available only when PhotoView is added in. The DisplayManager
lists the lights applied to the currently active model. Controls for shadows and fog now
provide a stronger integration with PhotoView. Light intensity is controlled with wattages.

Lighting controls are separate for SolidWorks and PhotoView 360.

By default, point, spot, and directional lights are on in SolidWorks.

Scene lighting is not possible in RealView, so you often need to
illuminate models manually.

SolidWorks

By default, lighting is off in PhotoView.

With lights off, you can use the realistic lighting provided by scenes,
which is usually sufficient for rendering. You typically need additional
lighting in PhotoView to illuminate occluded spaces in the model.

PhotoView

The icons for specific lights in this image from the Scene, Lights, and Cameras pane of
the DisplayManager have the following meanings:

On in SolidWorks

Off in PhotoView

Directional1

Off in SolidWorks

Off in PhotoView

Spot1

Off in SolidWorks

On in PhotoView

Point1

On the DisplayManager tab, click View Scenes, Lights, and Cameras .

See SolidWorks Help: Lights.



Scene functionality is enhanced to allow full control of the scene that is visible behind the
model. The DisplayManager lists the background and environment applied to the currently
active model. The new Edit Scene PropertyManager, available from the View Scene pane
in the DisplayManager, lets you size the floor, control the background or environment,
and save custom scenes.

On the DisplayManager tab, click View Scenes, Lights, and Cameras .

Scenes are simplified and now consist of the following:

• A spherical environment based on a preset scene or image you select is mapped around
the model.

• A 2D background that can be a single color, a gradient of color, or an image you select.
Although partially obscured by the background, elements of the environment are
reflected in the model. You can also turn off the background and show the spherical
environment instead.

• A 2D floor on which you can see shadows and reflections. You can change the distance
of the model from the floor.

The Insert Picture functionality is removed. Background images in legacy models are
discarded and are not displayed. You can use the Edit Scene PropertyManager to add a
background image to the scene.

To save a custom scene, click Save Scene on the Advanced tab of the Edit Scene
PropertyManager.

Office Space scene



Rooftop scene

Warm Kitchen scene

See SolidWorks Help: Scenes.

Decals are now part of SolidWorks Standard. Use the DisplayManager to view and manage
decals applied to the current model.

On the DisplayManager tab, click View Decals .

See SolidWorks Help: Decals.
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This chapter includes the following topics:

• Manual Mode for Creating Parting Surfaces

You can create parting surfaces using Manual Mode, which lets you modify surface
direction. Manual Mode lets you override the defined parting surface direction and
manually create a portion of the surface.

Select Manual Mode in the Parting Surface PropertyManager to display handles that you
can manipulate to adjust the parting surface. To further modify the surface, right-click
an inner vertex and select Start fill surface region or End fill surface region.

The first image below shows an irregular parting surface. In the second image the surface
has been fixed.
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This chapter includes the following topics:

• Parts

• Features

• Surfaces

• FeatureWorks

Defeature for Parts

With the Defeature tool, you can remove details from a part or assembly and save the
results to a new file in which the details are replaced by dumb solids (that is, solids without
feature definition or history). You can then share the new file without revealing all the
design details of the model.

Click Defeature (Tools toolbar) or Tools > Defeature to access the Defeature
PropertyManager, which provides tools for manual and automatic selection of details to
keep and remove.

AfterBefore

For a step-by-step example, see Defeature for Assemblies on page 25.

Equations

Sharing Equations Among Models
You can share equations and global variables among models.

You export selected equations and variables from a model to an external text (.txt) file.
Alternatively, you can build the text file manually using an application such as Notepad.
Then you import information from the text file into other models. You can choose to link



models to the text file, so that changes you make in the text file update the equations
and variables in the models.

Exporting Equations

In this example, you export equations from a part to a text file.

1. Open install_dir\samples\whatsnew\parts\frontplate_01.sldprt.

2. Click Tools > Equations.
The Equations dialog box lists five equations.

3. Click Export.
All the equations are listed in the Equations Export dialog box. Under Active, all the
equations are selected for export. Link to file is selected as well.

4. Click Save.

5. In the Save As dialog box, for File name, type my_equations.

6. Click Save.
The equations are saved in a text file. The text file is available to import into other
parts and assemblies. Because Link to file was selected, changes you make in the
text file are propagated to the model.

In the Equations dialog box:

• Under Active, the icon indicates equations that are linked to the external file.

• At the bottom of the dialog box, Linked File displays the path to the external
file.

7. Click OK.

8. Save the part. If prompted to rebuild, click Yes.

Importing Equations

Now import the equations from the text file to another part.

1. Open install_dir\samples\whatsnew\parts\backplate_01.sldprt.

2. Click Tools > Equations.

3. In the Equations dialog box, click Import.

4. In the Open dialog box:

a) Select my_equations.txt.

b) Select Link to file.

c) Click Open.

Five equations are imported into the model.



In the Equations dialog box:

• Under Active, the icon indicates equations that are linked to the external file.

• At the bottom of the dialog box, Linked File displays the path to the external
file.

5. Click OK.

6. Click Rebuild (Standard toolbar).
The equations are applied to the model.

7. Save the part.

Suppression States of Features and Components
You can use equations to control the suppression state of part features and assembly
components.

In the Add Equation dialog box, you use the Visual Basic IIf function to specify when to
suppress or unsuppress a feature or component.

The syntax of the Visual Basic IIf function is:

iif(expression, truepart, falsepart)

where:

• expression is the expression you want to evaluate

• truepart is the value to use if expression is true

• falsepart is the value to use if expression is false

Defining a Feature Suppression Equation

In this example, you suppress a hole in a plate when the length of the plate is less than
40 mm.

The hole you want to suppress is part of a linear pattern, so you define an equation to
suppress or unsuppress the linear pattern feature depending on the part length.

To suppress the feature:

1. Open frontplate_01.sldprt from the previous example.

2. In the FeatureManager design tree, right-click Equations and click Add Equation.
The Equations and Add Equations dialog boxes open.

3. In the FeatureManager design tree, click the linear pattern feature LPattern1.



"LPattern1" appears in the Add Equations dialog box.

If Instant 3D is active, you need to click-pause-click LPattern1. The first click
selects the linear pattern. The second click adds it to the Add Equations dialog
box.

4. In the dialog box, complete the equation:

"LPattern1" = iif ("overall length"<40, "suppressed", "unsuppressed" )

You can type the entire equation or use the following tips to enter various pieces:

• To insert global variable "overall length", expand Equations in the
FeatureManager design tree and click "overall length"=100.

• To insert "suppressed" and "unsuppressed", click the suppress and
unsuppress buttons in the dialog box.

5. Click OK.
The new equation is added to the Equations dialog box.

6. Click OK.

Testing the Feature Suppression Equation

Now decrease the length of the part to 35 mm, which triggers the suppression of the
linear pattern feature.

The length of the part (length@outline) is controlled by the global variable "overall

length", which is defined in the linked external file.

To trigger the suppression state equation:

1. Open my_equations.txt.

2. For "overall length", change 100 to 35.

3. Save the text file.

4. Click Rebuild (Standard toolbar).
The external equations file is checked for changes and the length of the part is updated
from 100 to 35. Because the length is now less than 40 mm, LPattern1 is suppressed,
which eliminates the second hole.

5. Edit my_equations.txt again, and change "overall length" back to 100.

6. Save and close the text file.

7. Click Rebuild (Standard toolbar).
The external equations file is checked for changes and the length of the part is updated
from 35 to 100. Because the length is now greater than 40 mm, LPattern1 is
unsuppressed.



8. Save the part.

Exporting the Feature Suppression Equation

Now add the new equation to the external text file.

1. In the FeatureManager design tree, right-click Equations and click Edit Equation.

2. In the dialog box, click Export.
The new equation appears at the bottom of the list.

3. Click Save.

4. In the Save As dialog box, select my_equations.txt and click Save. When asked to
replace the existing file, click Yes.

5. Click OK.

6. Open my_equations.txt.
The feature suppression equation appears in the text file.

Defining a Component Suppression Equation

Now use an equation to suppress a component in an assembly.

1. Open install_dir\samples\whatsnew\parts\plate_assembly_111.sldasm. If
prompted to rebuild, click Yes.

First, import my_equations.txt so that you can use the global variable "overall

length" in the component suppression equation.

2. Click Tools > Equations.

3. In the Equations dialog box, click Import.

4. In the Open dialog box:

a) Select my_equations.txt.

b) Select Link to file.

c) Click Open.

Because the assembly does not contain all the same dimensions as the parts, warnings
about invalid equations appear.

5. Click OK to dismiss each warning.



Two equations are imported into the model, including global variable "overall

length".

6. Click OK to close the Equations dialog box.

Now add an equation to suppress the second instance of the pin when overall length
is less than 40 mm.

7. In the FeatureManager design tree, right-click Equations and click Add Equation.

8. In the FeatureManager design tree, click pin<2>.
"pin<2>" appears in the Add Equation dialog box.

9. In the dialog box, complete the equation:

"pin<2>" = iif ( "overall length"<40, "suppressed" , "unsuppressed" )

You can type the entire equation or use the following tips to enter various pieces:

• To insert global variable "overall length", expand Equations in the
FeatureManager design tree and click "overall length"=100.

• To insert "suppressed" and "unsuppressed", click the suppress and
unsuppress buttons in the dialog box.

10. Click OK.
The new equation is added to the Equations dialog box.

11. Click OK.

12. Save the assembly. In the Save Modified Documents dialog box, click Save All . If
prompted to rebuild, click Yes.

Testing the Component Suppression Equation

Now decrease the overall length to 35 mm, which triggers the suppression of the linear
pattern feature in the two parts and the suppression of the second instance of the pin in
the assembly.

1. In my_equations.txt, for "overall length", change 100 to 35.

2. Save the text file.

3. In the assembly, click Rebuild (Standard toolbar).
The length of the plates changes to 35 mm and the linear pattern is suppressed. In
the assembly, the second instance of the pin is suppressed.

Global Variables

You can configure global variables.

In a design table, the column header for controlling the value of a global variable uses
this syntax:



$VALUE@global_variable_name@equations

In the table body cells, type the value for the global variable. If you leave a cell blank, it
inherits the value from the configuration that was active when you opened the design
table.

Example:

Helix

The PropertyManager and callouts are enhanced. Methods of defining a Variable pitch
helix have been expanded.

PropertyManager and Callouts
The PropertyManager and callouts display more information.

• Callouts for Constant pitch cases are now displayed in the graphics area, similar to
those that already appear for Variable pitch cases.

• The callouts show all parameters, including those that are for information only (shown
in gray).

• In the PropertyManager, for Variable pitch, the table now shows all parameters,
including those that are inactive or for information only (shown in gray).

Variable Pitch Helix
You can define a Variable pitch helix by specifying Height and Revolution.



Previously, only Pitch and Revolution and Height and Pitch were available for Variable
pitch, and you could use Height and Revolution only when defining a Constant pitch
helix.

In a part, select a sketch that contains a circle. Click Insert > Curve > Helix/Spiral.
In the PropertyManager, under Defined By, select Height and Revolution. Under
Parameters, select Variable pitch. Enter values for H and Rev in the table.

Revolve

More end conditions are available when creating a revolve feature.

New end conditions include:

• Up To Vertex

• Up To Surface

• Offset From Surface

You can specify separate end conditions for each direction (clockwise and counter-clockwise
from the sketch plane).

The new end conditions are available when you click the following:

• Revolved Boss/Base (Features toolbar) or Insert > Boss/Base > Revolve

• Revolved Cut (Features toolbar) or Insert > Cut > Revolve

• Revolved Surface (Surfaces toolbar) or Insert > Surface > Revolve

In the PropertyManager, under Direction1, in Revolve Type, select an end condition.
Select Direction2 to specify an end condition for the second direction.

Example: For this revolved boss, the end condition is Up To Surface for Direction1 and
Direction2:



Scale

You can configure the X, Y, and Z scale factors.

Use one of the following methods:

Under Configurations, specify the configurations to which the scale
factors apply.

PropertyManager

The column headers for controlling the X, Y, and Z factors of a scale
feature use this syntax:

$X_AXIS@scale_feature_name

Design Table

$Y_AXIS@scale_feature_name

$Z_AXIS@scale_feature_name

Example:

For uniform scaling, only $X_AXIS@scale_feature_name needs
to be defined.

Surface Extrudes From a 2D or 3D Face

You can create extruded surfaces from models that include 2D or 3D faces and knit the
extruded surfaces to surrounding features.



Click Insert > Surface > Extrude.

1. Select a face:

• To extrude from a 3D face, select a 3D face.

• To extrude from a 2D face, press Alt + select the planar face.

2. Select the end condition.

3. For 3D faces, select a plane, edge, 2D face, or sketch line to define the direction of

extrusion .

Select a plane to define an extrude direction normal to the plane.

4. To remove the faces defining the extrude from the model after extruding, click Delete
original faces.

5. To create a single body from the extrude when faces are deleted, select Knit result

.

6. Set other options and click .

Surface Extrudes from Faces

You can create extruded surfaces from models that include 2D or 3D faces and knit the
extruded surfaces to surrounding features.

In this example, you examine a part that has two surface extrudes. Both extrudes are
created from three contiguous faces: one planar face and two 3D faces.



Opening the Model

First, you open the model and examine some components.

1. Open
install_dir\samples\whatsnew\surfaces\multiface-surf-extrude_example.SLDPRT.

2. Notice the surface extrude features in the FeatureManager design tree.

The two extrusions into and out of the central portion of the model were created by
selecting three faces, deleting the original faces, and capping one end of the extrusion.



Viewing the Surface Extrude Options

Next, you examine the options used to specify the surface extrude for the model.

1. Click Surface-Extrude2 and click Edit Feature .

2. To view one of the 3D faces used to create the surface extrude, select Face<1>
under Faces to Extrude in the PropertyManager.

3. To view the other faces used to create the surface extrude, select each of them under
Faces to Extrude in the PropertyManager.



A 3D face defines each end portion
of the extude.

A planar face defines the middle
portion of the extrude.

4. To display the plane defining the direction of extrusion, click Front Plane in the
PropertyManager.

Notice the extrude direction is normal to the front plane.

5. Note the selected options:

• Cap end. Seals the Direction 1 end of the extrude with a translated copy of the
selected 3D face.

• Delete original faces . Deletes the faces selected under Faces to Extrude

. The 3D faces are removed from the model.

• Knit result . Knits the resulting extrude to the surface boundary where the
original face is deleted.

6. Close the PropertyManager.



To examine the other surface extrude created from 3D faces, rotate the model
and repeat Steps 1 - 6 for Surface-Extrude3.

Viewing the Original Surface Before the Extrude

Next, you suppress a surface extrude to view the surface before the extrude.

1. Click Surface-Extrude2 and select Suppress .

The three faces were created by splitting the surfaces with a Split Line feature.

2. Press Ctrl + select the three faces in the middle to view the original surface used to
create this model.

3. Close the model without saving it.



Capping an Extruded Surface

You can cap an extruded surface at one end or at both ends.

Click Insert > Surface > Extrude. To seal an end of the extrude, under Direction 1
in the PropertyManager, select Cap end.

You can seal the other end of the extrude by selecting Cap end under Direction
2. When you cap both ends of an extrude to define an enclosed volume, a solid is
created automatically.

Set other options and click .

Available in SolidWorks Professional and SolidWorks Premium.

Bosses and Cuts Recognition

Feature recognition is enhanced and new feature types are recognized.

Interactive Recognition of Boss and Cut Sweeps
FeatureWorks recognizes boss sweep and cut sweep features during interactive
recognition when two faces are selected.
Boss Sweep

1. Open install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-BossSweep.x_t.

2. First recognize the upper boss sweep. During interactive recognition of boss sweep
features, select End Face1 and End Face 2/Support Face.

3. Then, recognize the lower boss sweep. Select End Face1 and End Face 2/Support
Face.



In the FeatureWorks PropertyManager under Interactive Features, the
Boss-Sweep feature type replaces Base-Sweep. Boss-Sweep recognizes both base
and boss sweeps.

Cut Sweep

1. Open install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-CutSweep.x_t.

2. Use interactive recognition and under Feature type, select Cut-Sweep.

3. Select End face and then select End Face 1.

4. Select End Face 2. If necessary, rotate the model.

Interactive Recognition of Cut Revolve Features
FeatureWorks recognizes cut revolve features of the type known as "pencil sharpening
cuts" during interactive recognition.

1. Open install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-Pencil.x_t.

2. During interactive recognition of cut revolve features, select the face of the cut revolved
feature.



Do not select the top planar face. Verify that Chain revolved faces is cleared.

Interactive and Automatic Recognition of Bosses and Cuts From Non-Planar
Faces
FeatureWorks recognizes extrude features (bosses and cuts) that are created from
non-planar faces in both interactive and automatic recognition modes.

1. Open
install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-NonPlanar_1.x_t.

2. Use automatic recognition and under Automatic Features, select Extrudes.

Previously, FeatureWorks could recognize only the highlighted boss extrude.

FeatureWorks now recognizes the original boss extrude as well as the four boss extrudes
created from the non-planar face.

The extrudes must be exact offsets from the supporting face.

1. Open
install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-NonPlanar_2.x_t.

2. Use automatic recognition and under Automatic Features, click Check all filters

.

FeatureWorks recognizes one base revolve, ten cut extrudes, nine holes, two chamfers,
and 42 fillets. FeatureWorks finds two circular patterns. FeatureWorks maps all of the
features automatically.



Recognized FeaturesOriginal Part

Automatic Recognition of Draft Features

FeatureWorks recognizes draft features during automatic recognition. Drafts were
previously recognized only in interactive mode.

1. Open install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-Draft.x_t.

2. In automatic recognition mode, select Standard features. Under Automatic Features,
select Drafts and Fillets/Chamfers only.

FeatureWorks maps all of the features automatically.

Combining Like Features During Automatic Feature Recognition

Automatic feature recognition can now combine fillets, chamfers, or holes of the same
geometry into a single feature. For example, seven fillets with the same radius are
recognized as one feature. This reduces the number of features in the FeatureManager
design tree and lets you group features together for better readability and smaller file
size.

1. Open
install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-CombineFeatures.x_t.

2. In automatic recognition mode, select Standard features. Under Automatic Features,
select Fillets/Chamfers.



Previously, FeatureWorks recognized 36 chamfers in this example. Now, one chamfer
feature appears in the FeatureManager design tree.

To turn off the combine features functionality, click FeatureWorks Options (Features
toolbar) or Insert > FeatureWorks > Options. On the Advanced Controls tab, under
Automatic Recognition, select or clear Combine Fillets, Combine Chamfers, or
Combine Holes.
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This chapter includes the following topics:

• Bend Calculation Tables

• Convert to Sheet Metal

• Flat Patterns

• K-Factor in Configurations

• Mapping Bend Directions When Exporting to DXF/DWG Files

• Mirroring Edge Flanges and Miter Flanges

• Sheet Metal Properties

• Patterns of Edge Flanges and Tab Features

You can calculate the developed length of sheet metal parts using bend calculation tables.

In previous releases, you calculated the developed length with K-Factor, bend table,
gauge table, bend allowance, and bend deduction methods. With bend calculation tables,
you can define different angular ranges, assign equations to those ranges, and calculate
the developed length of the part.

Click any sheet metal tool where you can select a calculation method for the developed
length. In the PropertyManager, under Bend Allowance, in Bend Allowance Type,
select Bend Calculation and set the options.

See SolidWorks Help: Bend Calculation Tables.

The Convert to Sheet Metal tool is enhanced.

Gauge Tables

You can use gauge tables with the Convert to Sheet Metal tool. The sheet metal
parameters (material thickness, bend radius, and bend calculation method) use the values
stored in the gauge table unless you override them.

Click Convert to Sheet Metal (Sheet Metal toolbar) or Insert > Sheet Metal >
Convert To Sheet Metal. In the PropertyManager, under Sheet Metal Gauges, select
Use gauge table and select a gauge table. You can specify the file locations for gauge
tables in Tools > Options > System Options > File Locations. In Show folders for,
select Sheet Metal Gauge Table.



Rip Types

You can define parameters for rip edges and rip sketches created with the Convert to
Sheet Metal tool. Available rip types are open butt, overlap, and underlap. You can also
control individual rip settings by clicking a rip callout in the graphics area. Additionally,
you can set the Default overlap ratio for all rips and show or hide callouts in the
graphics area.

Click Convert to Sheet Metal (Sheet Metal toolbar) or Insert > Sheet Metal >
Convert To Sheet Metal. In the PropertyManager, under Corner Defaults, select a rip
type and set the options.

See SolidWorks Help: Converting a Solid Part to a Sheet Metal Part.

Keep or Consume Solid Bodies

When using the Convert to Sheet Metal tool, you can keep the solid body to use with
multiple Convert to Sheet Metal features or specify that the entire body be consumed
by the tool.

Machine with a sheet metal enclosure.

Use Convert to Sheet Metal to create the
first sheet metal body. Keep body is
selected. You want to keep the solid body
to derive another sheet metal body from
the same solid body.



Use Convert to Sheet Metal to create the
second sheet metal body. Keep body is
cleared so the solid body is consumed.

Click Convert to Sheet Metal (Sheet Metal toolbar) or Insert > Sheet Metal >
Convert To Sheet Metal. In the PropertyManager, under Sheet Metal Parameters,
select or clear Keep body.

Bend Allowance

You can select the bend allowance method for the developed length calculation of the
part. In previous releases, you completed the Convert to Sheet Metal command and
then changed the bend allowance in a separate step.

Click Convert to Sheet Metal (Sheet Metal toolbar) or Insert > Sheet Metal >
Convert To Sheet Metal. In the PropertyManager, under Custom Bend Allowance,
select a bend allowance.

Callouts

You can show or hide callouts for Bend Edges, Rip Edges found, and Rip Sketches.

Click Convert to Sheet Metal (Sheet Metal toolbar) or Insert > Sheet Metal >
Convert To Sheet Metal. In the PropertyManager, select or clear Show callouts.

Improvements to flattening sheet metal parts make flattening succeed for complex shapes
which previously failed. These improvements also provide better flattened geometry for
certain corner treatments, lofted bends, and in some cases where cuts intersect bend
regions.

You can update existing flat patterns created prior to SolidWorks 2011 to use the improved
method.

In the FeatureManager design tree, right-click Flat-Pattern and click Edit Feature. In
the Flat-Pattern PropertyManager, under Parameters, select Recreate flat-pattern.

When you use K-Factor as the bend allowance type in sheet metal parts, you can specify
different values for the K-Factor in different configurations.



In the FeatureManager design tree, right-click Sheet-Metal1 and click Configure
feature. In the dialog box, in Sheet-Metal1, select the variable that corresponds to
K-Factor. Set the K-Factor values for each configuration.

You can map bend line directions to specific layers when you export sheet metal models
as .dxf or .dwg files. For example, in sheet metal parts with up and down bend directions,
you can map the different bend line directions to separate layers when you export the
part.

See Exporting Bend Line Directions on page 81.

You can mirror edge flanges that consist of several flanges attached to different edges.
You can also mirror modified miter flanges where the flanges are shortened so the
geometry does not overlap.

Mirrored edge flangesPart with multiple edge flanges

New properties specific to sheet metal parts are calculated and displayed in the Cut-List
Properties dialog box.

Some of the properties that are calculated are based on the bounding box, the smallest
rectangle in which the flat pattern can fit. You can set a grain direction to determine the
smallest rectangle that aligns with the grain direction to fit the flat pattern. The bounding
box is represented by a sketch when you flatten the sheet metal part and is located in

the FeatureManager design tree under Flat-Pattern .

When exporting a sheet metal part as a .dxf or .dwg file, you can export the bounding
box and assign the bounding box to a specific layer.

See Exporting Sheet Metal Parts to DXF or DWG Files on page 80.

The following properties are calculated in sheet metal parts:



Longest side of the bounding boxBounding Box Length

Shortest side of the bounding boxBounding Box Width

Bounding box length x Bounding box widthBounding Box Area

Area of the flat pattern excluding the through cut-outsBounding Box Area-Blank

Outer perimeter of the flat pattern (blank), which is
used for calculating the machine’s cutting time

Cutting Length-Outer

Sum of the perimeters of internal loops or cut-outsCutting Length-Inner

Closed cut outs (through holes) on the flat pattern,
which are used for calculating the machine’s idle time

Cut Outs

Number of bends in the partBends

To view these properties, in the FeatureManager design tree, expand Cut list . Right-click

a Cut-List-Item and click Properties. The properties are updated whenever you
update the cut list or flatten the part.

See SolidWorks Help: Sheet Metal Properties and Setting the Grain Direction for Bounding
Boxes.

You can pattern edge flanges and tab features that have additional sheet metal features
attached.

The patterns are supported for the same sheet metal body only. Multibody is not supported.
Pattern tools include linear, circular, curve driven, sketch driven, and table driven patterns.

You cannot pattern tab features with attached jogs or sketched bends.



See SolidWorks Help: Creating a Grid System.

The graphics area can appear cluttered when the grid system creates a lot of geometry
or if you create multiple grid systems. To reduce clutter, you can hide the geometry.
Display options are available to help you visualize the grid structure and to ensure correct
grid inferencing.

To access the display options, in the FeatureManager design tree, right-click Grid System

and click View Grid Components. In the View Grid Components dialog box, select

an item and click a display option, such as Normal To .
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This chapter includes the following topics:

• New Supported Regions

• Sustainability Link for Custom Material

SolidWorks Sustainability and SustainabilityXpress support these additional regions:
South America, Australia, and India. You can specify the regions as Manufacturing
or Transportation and Use regions.

You can perform a sustainability analysis using custom materials. This is done by linking
your custom material to a material with similar characteristics in the default SolidWorks
Materials database. The analysis is then performed using the Sustainability characteristics
of the SolidWorks material.

To link your custom material to a similar material:

1. In the Material dialog box, in a custom materials library, select your custom material.

2. In the Properties tab, in Material properties, click Select.

3. In the Match Sustainability Information dialog box, select the material that is most
similar to your custom material.

Only materials with a link to the Sustainability database are listed.

4. Click OK.

5. Click Apply and Close.



28

This chapter includes the following topics:

• Cut Lists

• Weld Beads

• Weld Support in Drawings

Cut List Icons

New icons appear in the FeatureManager design tree under Cut list.

The icons are based on the type of body in the model:

• Sheet Metal

• Weldment or structural members

• Other bodies

Reordering and Excluding Cut List Items

You can reorder Cut-List-Item folders. Because the order of the Cut-List-Item folders
drives the cut list entries, you can apply a customized order to the cut list. The reordering
propagates to the cut lists in the part and drawing. You can also exclude Cut-List-Item
folders from cut lists.

To reorder the Cut-List-Item folders:

• Drag and drop folders in the FeatureManager design tree.

• Use the Cut-List Properties dialog box to drag and drop folders on the Cut List Summary
or Cut List Table tabs.

To exclude Cut-List-Item folders from cut lists:

• Right-click a folder in the FeatureManager design tree and click Exclude from cut list.

• Use the Cut-List Properties dialog box to select Exclude from cut list on the Cut List
Summary and Cut List Table tabs.

See SolidWorks Help: Excluding Folders from Cut Lists.

You should finish modeling the part before modifying the cut list items. You may
lose changes to the cut list if you change the geometry after modifying the cut list.

You can add simplified weld beads to weldment parts and assemblies, and multibody
parts.



Benefits of simplified weld beads:

• Uniform implementation in parts and assemblies

• Compatiblity with all types of geometry, including bodies with gaps

• Lightweight, simplified weld bead display

• Inclusion of weld bead properties in drawings using weld tables

• Smart Weld selection tool for face selection of weld bead paths

• Association of weld bead symbols with the weld beads

• Handles that assist in defining weld paths (lengths)

• Inclusion in the Weld Folder in the FeatureManager design tree

Additionally, you can set properties for Weld Sub Folders, including:

• Weld material

• Weld process

• Weld mass per unit length

• Welding cost per unit mass

• Welding time per unit length

• Number of weld passes

Click Weld Bead (Weldments toolbar) or Insert > Weldments > Weld Bead. In
an assembly, click Insert > Assembly Feature > Weld Bead.

Weld Bead Display

Weld beads are displayed as graphical representations in models. The weld beads are
lightweight and do not affect performance.

Weld Beads in Assemblies

Weld Beads
You can add simplified weld beads to assemblies.



In previous versions of SolidWorks , you added weld beads as components of the
assembly. This method is no longer supported. However, you can still edit existing
weld bead components.

Fillets and Chamfers
In assemblies, you can create fillets and chamfers, which are useful for weld preparation.
As with other assembly features, you can propagate these features to the parts they
affect.

Example: Adding Chamfers and Weld Beads to an Assembly
In this example, you add chamfers to two plates to prepare them for welding. Then you
add a simplified weld bead.

Adding a Chamfer to an Assembly Component

First, add a chamfer to the plate on the right.

1. Open install_dir\samples\whatsnew\assemblies\plate_assembly.sldasm.

2. Click Assembly Features (Assembly tab on the CommandManager) and click

Chamfer , or click Insert > Assembly Feature > Chamfer.

3. In the PropertyManager, under Chamfer Parameters, for Edges and Faces or

Vertex , do the following to select the edge of plate01:

a) Right-click the top edge between the two plates and click Select Other.



b) In the dialog box, select Edge@[plate01<1>].
A preview of the chamfer appears.

4. Under Chamfer Parameters:

a) Select Angle distance.

b) Set Distance to 5.

c) Set Angle to 45.

Under Feature Scope, you can select Propagate feature to parts if you want
to add the chamfer to the plate's part file.

5. Click .
The chamfer appears.

Adding a Chamfer to a Second Component

Now add a chamfer to the other plate.

1. Select the edge of the plate.



2. Click Assembly Features (Assembly tab on the CommandManager) and click

Chamfer .
A preview of the chamfer appears.

3. In the PropertyManager, click .
The chamfer appears in the second plate.

Adding a Weld Bead

Now add a weld bead to the assembly.

1. Do one of the following:

• Click Weld Bead (Weldments toolbar).

• Click Assembly Features (Assembly tab on the CommandManager) and click

Weld Bead .

• Click Insert > Assembly Feature > Weld Bead.

2. In the PropertyManager, under Settings:

a) For Weld selection, select the faces of the two chamfers in the graphics area.



b) Set Bead size to 15.

3. Click .
The weld bead appears in the graphics area.

In the FeatureManager design tree, Weld Folder appears. Weld bead features
that have identical properties are stored together in subfolders. Weld Bead1 is
the weld you just created.

Weld Symbols

• In drawings, you can insert bi-directional weld symbols that are attached to weld paths.
Click Insert > Model Items and under Annotations, click Weld Symbols.

• You can insert weld symbols, caterpillars, and end treatments for weld beads in specific
views. Click Insert > Model Items and under Source/Destination, click Selected
feature for Source. Under Annotations, click Weld Symbols, Caterpillar, or End
Treatment. Move the pointer to highlight a weld path and click to place the annotation.
You can also select weld bead features from the FeatureManager design tree while in
the Model Items command.

Weld Tables

You can insert weld tables in a drawing that summarize the weld bead data.

By default, weld tables include:

• Weld size

• Symbol

• Weld length

• Weld material



• Quantity

You can add other weld bead custom properties to the table such as weld cost and weld
time, and save it as a template for future use.

In a drawing view, click Weld Table (Table toolbar) or Insert > Tables > Weld

Table. In the PropertyManager, set the options and click .


